aboutsummaryrefslogtreecommitdiffstats
path: root/tools/sstrip/Makefile
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2020-11-25 21:28:17 +0000
committerPaul Spooren <mail@aparcar.org>2020-11-26 12:44:25 -1000
commit3f567d8452644dc5349addabbb8f0bff9d0bc2c0 (patch)
tree2c79a050bbe2089e699c61f4bef093b522ed7ae2 /tools/sstrip/Makefile
parent6429307a3d6ba4c88d477cc7a3995be314e3dd15 (diff)
downloadupstream-3f567d8452644dc5349addabbb8f0bff9d0bc2c0.tar.gz
upstream-3f567d8452644dc5349addabbb8f0bff9d0bc2c0.tar.bz2
upstream-3f567d8452644dc5349addabbb8f0bff9d0bc2c0.zip
tools/sstrip: update to latest version
Drop our local sstrip copy and use the current ELFKickers upstream version. Patch the original makefile in order to avoid building elftoc, since it fails with musl's elf.h. This is fine, since we only need sstrip anyway. Finally, add the possibility to pass additional arguments to sstrip and pass -z (remove trailing zeros) by default, which matches the behaviour of the previous version. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com> [shorten long commit msg lines] Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'tools/sstrip/Makefile')
-rw-r--r--tools/sstrip/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/tools/sstrip/Makefile b/tools/sstrip/Makefile
index bab172a95a..b41c46d95c 100644
--- a/tools/sstrip/Makefile
+++ b/tools/sstrip/Makefile
@@ -7,17 +7,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sstrip
-PKG_VERSION:=2.0
+PKG_VERSION:=3.1a
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/ELFkickers-$(PKG_VERSION)
+PKG_SOURCE_URL:=https://www.muppetlabs.com/~breadbox/pub/software
+PKG_SOURCE:=ELFkickers-$(PKG_VERSION).tar.gz
+PKG_HASH:=06430880aaf4919c5f99fc629da7000347421668c2cf32bced2d401aac276508
+
PKG_RELEASE:=1
include $(INCLUDE_DIR)/host-build.mk
-define Host/Compile
- $(HOSTCC) $(HOST_CFLAGS) -include endian.h -o $(HOST_BUILD_DIR)/sstrip src/sstrip.c
-endef
-
define Host/Install
- $(CP) $(HOST_BUILD_DIR)/sstrip $(STAGING_DIR_HOST)/bin/
+ $(CP) $(HOST_BUILD_DIR)/bin/sstrip $(STAGING_DIR_HOST)/bin/
endef
define Host/Clean