aboutsummaryrefslogtreecommitdiffstats
path: root/tools/squashfskit4
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2018-12-12 16:10:42 +0100
committerAlexander Couzens <lynxis@fe80.eu>2019-02-28 01:38:46 +0100
commit889b6423b78bcde8af81d68a3fabcdd019181de4 (patch)
tree1855cb252ea7297bb74901a9955a33347512ebc0 /tools/squashfskit4
parent9e8cbecb7f188dcf31b3a4e268d8e2b8e6d55a58 (diff)
downloadupstream-889b6423b78bcde8af81d68a3fabcdd019181de4.tar.gz
upstream-889b6423b78bcde8af81d68a3fabcdd019181de4.tar.bz2
upstream-889b6423b78bcde8af81d68a3fabcdd019181de4.zip
tools: migrate from squashfs4 to squashfskit4
squashfskit is a fork of the squashfs-tools. squashfskit creates reproducible filesystems and includes many of the distro patches. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> Tested-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'tools/squashfskit4')
-rw-r--r--tools/squashfskit4/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/tools/squashfskit4/Makefile b/tools/squashfskit4/Makefile
new file mode 100644
index 0000000000..4808c5607f
--- /dev/null
+++ b/tools/squashfskit4/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2009-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=squashfskit4
+PKG_VERSION:=4.14
+
+PKG_SOURCE:=squashfskit-v$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/squashfskit/squashfskit/releases/download/v$(PKG_VERSION)/
+PKG_HASH:=5761aaa3aedc4f7112b708367d891c9abdc1ffea972e3fe47923ddba23984d95
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/squashfskit-v$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ +$(HOST_MAKE_VARS) \
+ $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+ XZ_SUPPORT=1 \
+ LZMA_XZ_SUPPORT=1 \
+ XATTR_SUPPORT= \
+ LZMA_LIB="$(STAGING_DIR_HOST)/lib/liblzma.a" \
+ EXTRA_CFLAGS="-I$(STAGING_DIR_HOST)/include" \
+ mksquashfs unsquashfs
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/mksquashfs $(STAGING_DIR_HOST)/bin/mksquashfs4
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/unsquashfs $(STAGING_DIR_HOST)/bin/unsquashfs4
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mksquashfs4
+ rm -f $(STAGING_DIR_HOST)/bin/unsquashfs4
+endef
+
+$(eval $(call HostBuild))