aboutsummaryrefslogtreecommitdiffstats
path: root/tools/sdcc
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-04-09 15:23:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-04-09 15:23:34 +0000
commitb409973545921c450538daa4e8b0f9ffe9b2a387 (patch)
treed8735b2aa5b8205511d81d1e051b531e083f40f8 /tools/sdcc
parent50eba35cd397748f9f36c0592a11ab1f2598516b (diff)
downloadupstream-b409973545921c450538daa4e8b0f9ffe9b2a387.tar.gz
upstream-b409973545921c450538daa4e8b0f9ffe9b2a387.tar.bz2
upstream-b409973545921c450538daa4e8b0f9ffe9b2a387.zip
add an sdcc host build which is enabled if firmwarehotplug is selected
SVN-Revision: 31226
Diffstat (limited to 'tools/sdcc')
-rw-r--r--tools/sdcc/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/tools/sdcc/Makefile b/tools/sdcc/Makefile
new file mode 100644
index 0000000000..1e827a6091
--- /dev/null
+++ b/tools/sdcc/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sdcc
+PKG_VERSION:=3.0.0
+
+PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=20fbd49a3421e09fe65577c45524c89e
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --disable-ucsim \
+ --disable-packihx \
+ --disable-sdcpp \
+ --disable-sdcdb \
+ --disable-gbz80-port \
+ --disable-z80-port \
+ --disable-ds390-port \
+ --disable-ds400-port \
+ --disable-pic-port \
+ --disable-pic16-port \
+ --disable-hc08-port \
+ --disable-avr-port \
+ --disable-xa51-port \
+ --enable-mcs51-port \
+ --enable-device-lib \
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))