aboutsummaryrefslogtreecommitdiffstats
path: root/tools/sdcc/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
commitcf1698c6370d6a64f5f70a2dc5652d1fbc62afc3 (patch)
tree8dea115df7f768723281ea58c0ce7d0c4180182b /tools/sdcc/Makefile
parent095fe8743b64a47ea2b13642934348f914d2a2bb (diff)
downloadupstream-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.tar.gz
upstream-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.tar.bz2
upstream-cf1698c6370d6a64f5f70a2dc5652d1fbc62afc3.zip
use HOST_STATIC_LINKING instead of hardcoding -static
SVN-Revision: 33140
Diffstat (limited to 'tools/sdcc/Makefile')
-rw-r--r--tools/sdcc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/sdcc/Makefile b/tools/sdcc/Makefile
index abedc3ca71..3210bb3e76 100644
--- a/tools/sdcc/Makefile
+++ b/tools/sdcc/Makefile
@@ -17,7 +17,7 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
include $(INCLUDE_DIR)/host-build.mk
-HOST_LDFLAGS += -static
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
HOST_CONFIGURE_ARGS += \
--disable-ucsim \
--enable-packihx \