aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pkgconf
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-23 01:16:17 -0800
committerHans Dedecker <dedeckeh@gmail.com>2020-12-31 10:03:21 +0100
commit31554e50d2c3d0707a40f9ed08b0d6999f584ba2 (patch)
tree59fde8c27d0a816ab8d63c4975e190bb75f912bc /tools/pkgconf
parentf3e45c45cba1a541693da840642b08226653dff4 (diff)
downloadupstream-31554e50d2c3d0707a40f9ed08b0d6999f584ba2.tar.gz
upstream-31554e50d2c3d0707a40f9ed08b0d6999f584ba2.tar.bz2
upstream-31554e50d2c3d0707a40f9ed08b0d6999f584ba2.zip
ccache: update to 4.1
Upstream switched to building with CMake. Adjust accordingly. Reapplied patch as upstream changed the file format. Added HOST_BUILD_PARALLEL for faster compilation. Added cmake tool dependency and removed circular dependencies as a result. Adjusted dependent tools to use NOCACHE as they are needed to build ccache. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/pkgconf')
-rw-r--r--tools/pkgconf/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/pkgconf/Makefile b/tools/pkgconf/Makefile
index 7d785aae39..0f56de0e29 100644
--- a/tools/pkgconf/Makefile
+++ b/tools/pkgconf/Makefile
@@ -19,6 +19,8 @@ include $(INCLUDE_DIR)/host-build.mk
unexport PKG_CONFIG
+HOSTCC := $(HOSTCC_NOCACHE)
+
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install
mv $(STAGING_DIR_HOST)/bin/pkgconf $(STAGING_DIR_HOST)/bin/pkg-config.real