aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pkgconf/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-28 11:19:31 -0800
committerPetr Štetiar <ynezz@true.cz>2020-03-01 21:36:00 +0100
commit867298cf47ab505dee738fc653b90fa0bc2d0428 (patch)
treeec71d1775038e4091c666df2849f4b04d533b7c8 /tools/pkgconf/Makefile
parentaf878339ae28391dd7509cd27496fa4ca8d2a339 (diff)
downloadupstream-867298cf47ab505dee738fc653b90fa0bc2d0428.tar.gz
upstream-867298cf47ab505dee738fc653b90fa0bc2d0428.tar.bz2
upstream-867298cf47ab505dee738fc653b90fa0bc2d0428.zip
tools/pkg-config: Replace with pkgconf
pkgconf is a newer, actively maintained implementation of pkg-config that supports more aspects of the pkg-config file specification and provides a library interface that applications can use to incorporate intelligent handling of pkg-config files into themselves (such as build file generators, IDEs, and compilers). Through its pkg-config compatibility interface (activated when it is run as "pkg-config"), it also can completely replace the original implementation. It is also lighterweight and does not require glib2, as pkg-config does. On other distros, pkgconf is symlinked to pkg-config. For simplicity here, it is renamed to pkg-config.real, as in the original package. Initial results have been positive. As before, pkgconf works as long as the pkg-config files point to the proper paths. Signed-off-by: Rosen Penev <rosenp@gmail.com> [backported upstream fix for Meson] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'tools/pkgconf/Makefile')
-rw-r--r--tools/pkgconf/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/tools/pkgconf/Makefile b/tools/pkgconf/Makefile
new file mode 100644
index 0000000000..cefee1edf0
--- /dev/null
+++ b/tools/pkgconf/Makefile
@@ -0,0 +1,33 @@
+#
+# Copyright (C) 2006-2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pkgconf
+PKG_VERSION:=1.6.3
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://distfiles.dereferenced.org/pkgconf
+PKG_HASH:=61f0b31b0d5ea0e862b454a80c170f57bad47879c0c42bd8de89200ff62ea210
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport PKG_CONFIG
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) install
+ mv $(STAGING_DIR_HOST)/bin/pkgconf $(STAGING_DIR_HOST)/bin/pkg-config.real
+ $(INSTALL_BIN) ./files/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config
+endef
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))