aboutsummaryrefslogtreecommitdiffstats
path: root/tools/patchelf
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-10 15:48:32 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-10 15:48:32 +0000
commit572b94308008ea0323cb11df945ad7c2313fc320 (patch)
treecf680a8e8630c5d8515b0019281ee9b08f112ebb /tools/patchelf
parenta2fcaa77fc02d8a3c64afe33b7002de677273d5a (diff)
downloadupstream-572b94308008ea0323cb11df945ad7c2313fc320.tar.gz
upstream-572b94308008ea0323cb11df945ad7c2313fc320.tar.bz2
upstream-572b94308008ea0323cb11df945ad7c2313fc320.zip
tools: add patchelf host build
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44376
Diffstat (limited to 'tools/patchelf')
-rw-r--r--tools/patchelf/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/tools/patchelf/Makefile b/tools/patchelf/Makefile
new file mode 100644
index 0000000000..ef8730e2d8
--- /dev/null
+++ b/tools/patchelf/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=patchelf
+PKG_VERSION:=0.8
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://nixos.org/releases/patchelf/patchelf-$(PKG_VERSION)
+PKG_MD5SUM:=5b151e3c83b31f5931b4a9fc01635bfd
+
+HOST_BUILD_PARALLEL:=1
+HOST_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/patchelf $(STAGING_DIR_HOST)/bin/patchelf
+endef
+
+$(eval $(call HostBuild))