aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mtools
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-07-24 20:39:00 +0000
committerJohn Crispin <john@openwrt.org>2012-07-24 20:39:00 +0000
commit25482a60b34d4c4c2d6ad1dd3c65bf1e8be79472 (patch)
tree9e68ef2d0faa29e7e28defbaab760997f53af9ec /tools/mtools
parent5e52619b763af5cff25d11865c29f84fdf8c5a25 (diff)
downloadupstream-25482a60b34d4c4c2d6ad1dd3c65bf1e8be79472.tar.gz
upstream-25482a60b34d4c4c2d6ad1dd3c65bf1e8be79472.tar.bz2
upstream-25482a60b34d4c4c2d6ad1dd3c65bf1e8be79472.zip
add mktools and dosfstools which are needed for the raspberry pi
Signed-off-by: Ian Ridge <ianridge [at] gmail.com> SVN-Revision: 32824
Diffstat (limited to 'tools/mtools')
-rw-r--r--tools/mtools/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/tools/mtools/Makefile b/tools/mtools/Makefile
new file mode 100644
index 0000000000..994ca8d0d5
--- /dev/null
+++ b/tools/mtools/Makefile
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mtools
+PKG_VERSION:=4.0.17
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=231741ac95802d03aa32f44edb768171
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) mcopy
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/mcopy $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mcopy
+endef
+
+$(eval $(call HostBuild))