aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mpc
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-19 15:43:08 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-19 15:43:08 +0000
commit6d59a298e848fc0638920e711b1481b4b7afa18c (patch)
treeba394c3a3587ba2faec9cff7415788c192ca6d3b /tools/mpc
parent26cd3eed25919ae06ed6bb1106b1d65a00aae8eb (diff)
downloadupstream-6d59a298e848fc0638920e711b1481b4b7afa18c.tar.gz
upstream-6d59a298e848fc0638920e711b1481b4b7afa18c.tar.bz2
upstream-6d59a298e848fc0638920e711b1481b4b7afa18c.zip
add gcc-4.5.0 preliminary support
SVN-Revision: 21033
Diffstat (limited to 'tools/mpc')
-rw-r--r--tools/mpc/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/tools/mpc/Makefile b/tools/mpc/Makefile
new file mode 100644
index 0000000000..3898830c0b
--- /dev/null
+++ b/tools/mpc/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpc
+PKG_VERSION:=0.8.1
+
+PKG_SOURCE_URL:=http://www.multiprecision.org/mpc/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=5b34aa804d514cc295414a963aedb6bf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+ifeq ($(HOST_OS),Darwin)
+ GNU_HOST_NAME:=
+ HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
+endif
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-mpfr=$(TOPDIR)/staging_dir/host \
+ --with-gmp=$(TOPDIR)/staging_dir/host
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR)/$(3); \
+ $(HOST_CONFIGURE_CMD) \
+ $(HOST_CONFIGURE_VARS) \
+ $(HOST_CONFIGURE_ARGS); \
+ )
+endef
+
+
+$(eval $(call HostBuild))