aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mkimage
diff options
context:
space:
mode:
authorEvgeniy Didin <Evgeniy.Didin@synopsys.com>2018-02-12 19:42:01 +0300
committerJohn Crispin <john@phrozen.org>2018-02-13 10:01:52 +0100
commit063fa4cfa28a6bdf502cebed3f984fc738bfad25 (patch)
treed7aaf63fb7f9001b61ff7f0be39b79042b421319 /tools/mkimage
parent1fe888554cde1604f2246e0ca5bb9c8e0560ef66 (diff)
downloadupstream-063fa4cfa28a6bdf502cebed3f984fc738bfad25.tar.gz
upstream-063fa4cfa28a6bdf502cebed3f984fc738bfad25.tar.bz2
upstream-063fa4cfa28a6bdf502cebed3f984fc738bfad25.zip
tools/mkimage: copy mkenvimage to bin directory
For some boards u-boot binary environment file is required, which is generated by mkenvimage utility. But in OpenWrt there is no separate support for mkenvimage, which is a part of u-boot tools. mkenvimage gets built in u-boot/tools as well as mkimage anyways. So lets just copy mkenvimage to the $(STAGING_DIR_HOST)/bin/ directory. Signed-off-by: Evgeniy Didin <Evgeniy.Didin@synopsys.com> CC: Alexey Brodkin <abrodkin@synopsys.com> CC: Hauke Mehrtens <hauke@hauke-m.de> CC: John Crispin <john@phrozen.org>
Diffstat (limited to 'tools/mkimage')
-rw-r--r--tools/mkimage/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index bfe60993e2..00f85ae272 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -37,10 +37,12 @@ endef
define Host/Install
$(CP) $(HOST_BUILD_DIR)/tools/mkimage $(STAGING_DIR_HOST)/bin/
+ $(CP) $(HOST_BUILD_DIR)/tools/mkenvimage $(STAGING_DIR_HOST)/bin/
endef
define Host/Clean
rm -f $(STAGING_DIR_HOST)/bin/mkimage
+ rm -f $(STAGING_DIR_HOST)/bin/mkenvimage
endef
$(eval $(call HostBuild))