aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mkimage/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2021-01-06 19:36:44 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-02-08 22:46:27 +0100
commite6ccb40ba5bedbc4a27ddea4a858f17c3496a43f (patch)
tree9f0ee1581d0310d45693a76e6e725c803c178ae4 /tools/mkimage/Makefile
parent3e7c7d444642c52148e5ed8c24450faba0396c97 (diff)
downloadupstream-e6ccb40ba5bedbc4a27ddea4a858f17c3496a43f.tar.gz
upstream-e6ccb40ba5bedbc4a27ddea4a858f17c3496a43f.tar.bz2
upstream-e6ccb40ba5bedbc4a27ddea4a858f17c3496a43f.zip
tools: mkimage: Update U-Boot to version 2021.01
* The fit image is now created with 0666 permission in upstream U-Boot remove our patch switch creates it with 0744 * The generated/autoconf.h file is created now as an empty file, it is not needed to remove this include any more. * Upstream lib/rsa/rsa-sign.c now includes stdlib.h instead of malloc.h * ALIGN_MASK was moved to imagetool.h, own patch should not be needed any more. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'tools/mkimage/Makefile')
-rw-r--r--tools/mkimage/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 90ecdaaa6e..6901d921cf 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -7,14 +7,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2020.04
+PKG_VERSION:=2021.01
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
https://mirror.cyberbits.eu/u-boot \
https://ftp.denx.de/pub/u-boot \
ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
+PKG_HASH:=b407e1510a74e863b8b5cb42a24625344f0e0c2fc7582d8c866bd899367d0454
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
@@ -24,6 +24,8 @@ define Host/Prepare
$(Host/Prepare/Default)
mkdir -p $(HOST_BUILD_DIR)/include/config
touch $(HOST_BUILD_DIR)/include/config/auto.conf
+ mkdir -p $(HOST_BUILD_DIR)/include/generated/
+ touch $(HOST_BUILD_DIR)/include/generated/autoconf.h
endef
define Host/Compile