aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mkimage/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-23 08:49:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-23 08:49:34 +0000
commitdcd3a74da01df1c2660e8fc67762a06746bd52c3 (patch)
tree5cd9680dae14b36b61679530eefc1d64f47259d2 /tools/mkimage/Makefile
parentd406a5208f6ff28b70993b3e9ae32e3f895f0335 (diff)
downloadupstream-dcd3a74da01df1c2660e8fc67762a06746bd52c3.tar.gz
upstream-dcd3a74da01df1c2660e8fc67762a06746bd52c3.tar.bz2
upstream-dcd3a74da01df1c2660e8fc67762a06746bd52c3.zip
tools/mkimage: avoid picking up unrelated /usr/include headers with the same name as internal header files (e.g. image.h), fixes #12232
SVN-Revision: 33519
Diffstat (limited to 'tools/mkimage/Makefile')
-rw-r--r--tools/mkimage/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 373d9bebb8..149aaa6f12 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -18,6 +18,13 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
include $(INCLUDE_DIR)/host-build.mk
+define Host/Prepare
+ $(Host/Prepare/Default)
+ rm -f \
+ $(HOST_BUILD_DIR)/include/errno.h \
+ $(HOST_BUILD_DIR)/include/malloc.h
+endef
+
define Host/Compile
rm -f $(HOST_BUILD_DIR)/tools/.depend
touch $(HOST_BUILD_DIR)/include/config.h