aboutsummaryrefslogtreecommitdiffstats
path: root/tools/meson
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-10-09 12:24:44 -0700
committerDaniel Golle <daniel@makrotopia.org>2021-10-10 19:39:32 +0100
commit7c0fb874436c0613a042c8b07aa00621d08f4eaa (patch)
treeac524f890923a4a6cb52328d12385108c1edd3b0 /tools/meson
parent81d694e30b4926fea057bd3e46d996a8f098b95a (diff)
downloadupstream-7c0fb874436c0613a042c8b07aa00621d08f4eaa.tar.gz
upstream-7c0fb874436c0613a042c8b07aa00621d08f4eaa.tar.bz2
upstream-7c0fb874436c0613a042c8b07aa00621d08f4eaa.zip
tools/meson: fix usage with SDK
The python path cannot be embedded in the meson binary as it changes with the SDK. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/meson')
-rw-r--r--tools/meson/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/meson/Makefile b/tools/meson/Makefile
index 0cf0efba47..1aab5d8fcb 100644
--- a/tools/meson/Makefile
+++ b/tools/meson/Makefile
@@ -21,7 +21,7 @@ endef
define Host/Install
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(HOST_BUILD_DIR)/packaging/create_zipapp.py $(HOST_BUILD_DIR) --interpreter $(STAGING_DIR_HOST)/bin/$(PYTHON) --outfile $(STAGING_DIR_HOST)/bin/meson
+ $(HOST_BUILD_DIR)/packaging/create_zipapp.py $(HOST_BUILD_DIR) --outfile $(STAGING_DIR_HOST)/bin/meson
$(INSTALL_DIR) $(STAGING_DIR_HOST)/lib/meson
$(INSTALL_CONF) files/openwrt-cross.txt.in $(STAGING_DIR_HOST)/lib/meson/
$(INSTALL_CONF) files/openwrt-native.txt.in $(STAGING_DIR_HOST)/lib/meson/