aboutsummaryrefslogtreecommitdiffstats
path: root/tools/lzma/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-13 22:51:49 +0200
committerFelix Fietkau <nbd@openwrt.org>2016-03-20 17:29:15 +0100
commit60c1f0f64d23003a19a07d6b9638542130f6641d (patch)
tree8fb2787f4c49baded97cd55e0c371fe1cffce2b6 /tools/lzma/Makefile
parentd58a09110ccfa95f06c983fe796806f2e035c9d2 (diff)
parentb3ce218b51746d3a576221ea542facf3a1703ab2 (diff)
downloadupstream-60c1f0f64d23003a19a07d6b9638542130f6641d.tar.gz
upstream-60c1f0f64d23003a19a07d6b9638542130f6641d.tar.bz2
upstream-60c1f0f64d23003a19a07d6b9638542130f6641d.zip
finally move buildroot-ng to trunk
Diffstat (limited to 'tools/lzma/Makefile')
-rw-r--r--tools/lzma/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/tools/lzma/Makefile b/tools/lzma/Makefile
new file mode 100644
index 0000000000..47f21d1f07
--- /dev/null
+++ b/tools/lzma/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lzma
+PKG_VERSION:=432
+
+PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/sevenzip
+PKG_MD5SUM:=155c1ebce5bc6710ae7ecc926226d9d7
+
+PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/lzma
+
+include $(INCLUDE_DIR)/host-build.mk
+
+LIB_DIR=$(PKG_BUILD_DIR)/C/7zip/Compress/LZMA_Lib
+ALONE_DIR=$(PKG_BUILD_DIR)/C/7zip/Compress/LZMA_Alone
+
+define Build/Prepare
+ bzcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/ $(TAR_OPTIONS) -
+ $(PATCH) $(PKG_BUILD_DIR) ./patches
+endef
+
+define Build/Compile
+ $(MAKE) -C $(LIB_DIR)
+ $(MAKE) -f makefile.gcc -C $(ALONE_DIR)
+endef
+
+define Build/Install
+ mkdir -p $(STAGING_DIR)/host/lib
+ $(CP) $(LIB_DIR)/liblzma.a $(STAGING_DIR)/host/lib/
+ mkdir -p $(STAGING_DIR)/bin
+ $(CP) $(ALONE_DIR)/lzma $(STAGING_DIR)/bin/
+endef
+
+define Build/Clean
+ rm -f $(STAGING_DIR)/host/lib/liblzma.a $(STAGING_DIR)/bin/lzma
+endef
+
+$(eval $(call HostBuild))