aboutsummaryrefslogtreecommitdiffstats
path: root/tools/libtool/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-18 18:07:53 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-18 18:07:53 +0000
commit51538948fec438915933adcd110653e1ddb32910 (patch)
treea698403515eec984b0b1559a8d665fc2d1edb14f /tools/libtool/Makefile
parentb40d260aaf6c6cd4dab390094a706dfa409e9012 (diff)
downloadupstream-51538948fec438915933adcd110653e1ddb32910.tar.gz
upstream-51538948fec438915933adcd110653e1ddb32910.tar.bz2
upstream-51538948fec438915933adcd110653e1ddb32910.zip
make libtool a tool build and let autoconf depend on it
SVN-Revision: 24673
Diffstat (limited to 'tools/libtool/Makefile')
-rw-r--r--tools/libtool/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/tools/libtool/Makefile b/tools/libtool/Makefile
new file mode 100644
index 0000000000..82730dfee8
--- /dev/null
+++ b/tools/libtool/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libtool
+PKG_VERSION:=2.4
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=b32b04148ecdd7344abc6fe8bd1bb021
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR)
+endef
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) install
+ $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(STAGING_DIR_HOST)/bin/libtool
+ $(CP) $(STAGING_DIR_HOST)/bin/libtool $(STAGING_DIR_HOST)/bin/libtool-ucxx
+ $(SED) 's,-lstdc++,-luClibc++,g' $(STAGING_DIR_HOST)/bin/libtool-ucxx
+endef
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))