aboutsummaryrefslogtreecommitdiffstats
path: root/tools/libtool/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-27 02:10:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-27 02:10:23 +0000
commit4a298f0c8d7b2ba1bfad3e2e6c2e9a0765dc2634 (patch)
treef21866ec89aff35bf36989b3b6184b4ab12b8d2e /tools/libtool/Makefile
parentc61b903d0520cf92aed682120003649e3159d22d (diff)
downloadupstream-4a298f0c8d7b2ba1bfad3e2e6c2e9a0765dc2634.tar.gz
upstream-4a298f0c8d7b2ba1bfad3e2e6c2e9a0765dc2634.tar.bz2
upstream-4a298f0c8d7b2ba1bfad3e2e6c2e9a0765dc2634.zip
move libtool out of tools/, seems like we need a per-target libtool
SVN-Revision: 9937
Diffstat (limited to 'tools/libtool/Makefile')
-rw-r--r--tools/libtool/Makefile43
1 files changed, 0 insertions, 43 deletions
diff --git a/tools/libtool/Makefile b/tools/libtool/Makefile
deleted file mode 100644
index ad2bcd4f4e..0000000000
--- a/tools/libtool/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libtool
-PKG_VERSION:=1.5.22
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/libtool
-PKG_MD5SUM:=8e0ac9797b62ba4dcc8a2fb7936412b0
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Build/Configure
- $(call Build/Configure/Default, \
- --disable-shared \
- --disable-static \
- )
-endef
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)
-endef
-
-define Build/Install
- $(MAKE) -C $(PKG_BUILD_DIR) install
-endef
-
-define Build/Clean
- $(MAKE) -C $(PKG_BUILD_DIR) uninstall clean
- $(call Build/Clean/Default)
-endef
-
-$(eval $(call HostBuild))