aboutsummaryrefslogtreecommitdiffstats
path: root/tools/libressl
diff options
context:
space:
mode:
authorThorsten Glaser <tg@mirbsd.org>2018-10-22 21:00:57 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-11-01 17:16:52 +0100
commita395563f68fde6f52dbf10913f59f13b8c804cd5 (patch)
tree95811f08f1640a29597841d9567aff011ca243b9 /tools/libressl
parent79b766d07d56d22536120de2066e2e203ed01eb0 (diff)
downloadupstream-a395563f68fde6f52dbf10913f59f13b8c804cd5.tar.gz
upstream-a395563f68fde6f52dbf10913f59f13b8c804cd5.tar.bz2
upstream-a395563f68fde6f52dbf10913f59f13b8c804cd5.zip
build: fix libressl build on x32 (amd64ilp32) host
disable use of assembly code since x32 gets misdetected as amd64 Signed-off-by: Thorsten Glaser <tg@mirbsd.org>
Diffstat (limited to 'tools/libressl')
-rw-r--r--tools/libressl/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/libressl/Makefile b/tools/libressl/Makefile
index 57cdacd961..8894a058e4 100644
--- a/tools/libressl/Makefile
+++ b/tools/libressl/Makefile
@@ -26,4 +26,8 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += --disable-shared
HOST_CFLAGS += $(FPIC)
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += --disable-asm
+endif
+
$(eval $(call HostBuild))