aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-01-13 14:14:11 +0100
committerRafał Miłecki <rafal@milecki.pl>2021-01-18 07:39:09 +0100
commiteaca08ab58afafc506f7313f2c1a763a11d9367e (patch)
tree43d0e5acce418f4db1d9abf5329219e936130161 /tools/firmware-utils/Makefile
parentf13b623f5e53a72b65f45cbaf56c73df35e70ed2 (diff)
downloadupstream-eaca08ab58afafc506f7313f2c1a763a11d9367e.tar.gz
upstream-eaca08ab58afafc506f7313f2c1a763a11d9367e.tar.bz2
upstream-eaca08ab58afafc506f7313f2c1a763a11d9367e.zip
firmware-utils: bcm4908img: tool adding BCM4908 image tail
Flashing image with BCM4908 CFE bootloader requires specific firmware format. It needs 20 extra bytes with magic numbers and CRC32 appended. This tools allows appending such a tail to the specified image and also verifying CRC32 of existing BCM4908 image. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index a8c6ab4f65..055082593b 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -27,6 +27,7 @@ define Host/Compile
$(call cc,add_header)
$(call cc,addpattern)
$(call cc,asustrx)
+ $(call cc,bcm4908img,-Wall)
$(call cc,bcm4908kernel,-Wall)
$(call cc,buffalo-enc buffalo-lib,-Wall)
$(call cc,buffalo-tag buffalo-lib,-Wall)