aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorSander Vanheule <sander@svanheule.net>2020-08-15 09:51:18 +0200
committerAlexander Couzens <lynxis@fe80.eu>2020-12-07 01:57:19 +0100
commitcb38170f4cd57ee028ab7b270f395cd1ee8adf00 (patch)
tree626464bac70448eea297a1d3b90746fdc1909528 /tools/firmware-utils/Makefile
parent1a211af2cb3be415a2c3454dea6fdc9a59bba334 (diff)
downloadupstream-cb38170f4cd57ee028ab7b270f395cd1ee8adf00.tar.gz
upstream-cb38170f4cd57ee028ab7b270f395cd1ee8adf00.tar.bz2
upstream-cb38170f4cd57ee028ab7b270f395cd1ee8adf00.zip
firmware-utils: tplink-safeloader: refactor meta-partition padding
Because some padding values in the TP-Link safeloader image generation were hardcoded, different values were sometimes used throughout a factory image. TP-Link's upgrade images use the same value everywhere, so let's do the same here. Although a lot of TP-Link's safeloader images have padded partition payloads, images for the EAP-series of AC devices don't. This padding is therefore also made optional. By replacing the type of the padding value byte with a wider datatype, new values outside of the previously valid range become available. Use these new values to denote that padding should not be performed. Because char might be signed, also replace the char literals by a numeric literal. Otherwise '\xff' might be sign extended to 0xffff. This results in factory images differing by 1 byte for: * C2600 * ARCHER-C5-V2 * ARCHERC9 * TLWA850REV2 * TLWA855REV1 * TL-WPA8630P-V2-EU * TL-WPA8630P-V2-INT * TL-WPA8630P-V2.1-EU * TLWR1043NDV4 * TL-WR902AC-V1 * TLWR942NV1 * RE200-V2 * RE200-V3 * RE220-V2 * RE305-V1 * RE350-V1 * RE350K-V1 * RE355 * RE450 * RE450-V2 * RE450-V3 * RE500-V1 * RE650-V1 The following factory images no longer have padding, shrinking the factory images by a few bytes for: * EAP225-OUTDOOR-V1 * EAP225-V3 * EAP225-WALL-V2 * EAP245-V1 * EAP245-V3 Signed-off-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 9c9a0ba40f..9a68b80c71 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME := firmware-utils
-PKG_RELEASE := 6
+PKG_RELEASE := 7
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/kernel.mk