aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-07-19 16:10:35 +0200
committerPetr Štetiar <ynezz@true.cz>2019-07-19 16:15:25 +0200
commit83e60f0df6e1f80011d454103fd4156d27dc7d98 (patch)
treeb622105113b5395a1fcc007a9fd95a33728a1818 /tools/firmware-utils/Makefile
parent9c0c1c44013003616e2f5c55c062430dbda3cce5 (diff)
downloadupstream-83e60f0df6e1f80011d454103fd4156d27dc7d98.tar.gz
upstream-83e60f0df6e1f80011d454103fd4156d27dc7d98.tar.bz2
upstream-83e60f0df6e1f80011d454103fd4156d27dc7d98.zip
firmware-utils: mkfwimage: enable extra compiler checks and fix them
Let's enforce additional automatic checks enforced by the compiler in order to catch possible errors during compilation. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index bde90f0ecd..eca4dd7da7 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -12,7 +12,13 @@ include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/kernel.mk
define cc
- $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_LDFLAGS) -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+ $(HOSTCC) \
+ $(HOST_CFLAGS) \
+ -Wno-unused-parameter \
+ -include endian.h $(HOST_LDFLAGS) \
+ -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) \
+ $(foreach src,$(1),src/$(src).c) \
+ $(2)
endef
define Host/Compile
@@ -32,7 +38,7 @@ define Host/Compile
$(call cc,mkzynfw)
$(call cc,lzma2eva,-lz)
$(call cc,mkcasfw)
- $(call cc,mkfwimage,-lz -Wall)
+ $(call cc,mkfwimage,-lz -Wall -Werror -Wextra)
$(call cc,mkfwimage2,-lz)
$(call cc,imagetag imagetag_cmdline cyg_crc32)
$(call cc,add_header)