aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorFUKAUMI Naoki <naobsd@gmail.com>2017-01-29 01:05:54 +0900
committerRafał Miłecki <rafal@milecki.pl>2017-01-31 10:55:02 +0100
commit7faee1bc9f9ede0e23de19d6156dc8d769431bb3 (patch)
tree1a29ef2ce5644eaf7d569b6073603cb23ac3793a /tools/firmware-utils/Makefile
parentbc32f7deb57706e6235ec82ed0e2637c63deadff (diff)
downloadupstream-7faee1bc9f9ede0e23de19d6156dc8d769431bb3.tar.gz
upstream-7faee1bc9f9ede0e23de19d6156dc8d769431bb3.tar.bz2
upstream-7faee1bc9f9ede0e23de19d6156dc8d769431bb3.zip
firmware-utils: improve tools for Buffalo DHP series
some of Buffalo DHP series use slightly different trx magic, buffalo-enc, buffalo-tag, and factory image begin with 'bgn'. this patch adds support for building those images. Signed-off-by: FUKAUMI Naoki <naobsd@gmail.com>
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 69cba69a58..2504678768 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -80,6 +80,7 @@ define Host/Compile
$(call cc,jcgimage, -lz -Wall)
$(call cc,mkbuffaloimg, -Wall)
$(call cc,zyimage, -Wall)
+ $(call cc,mkdhpimg buffalo-lib, -Wall)
endef
define Host/Install