aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-04-06 20:29:35 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-04-06 20:29:35 +0200
commit7f3facfce29639ec50677aa2b0eecebe259aa4d3 (patch)
tree6cd94a004f331f6db438fefcca011c6d3db6fe50 /tools/firmware-utils/Makefile
parentb812a7fa689a5a6dea3a9047108e2f1d1ec1cf36 (diff)
downloadupstream-7f3facfce29639ec50677aa2b0eecebe259aa4d3.tar.gz
upstream-7f3facfce29639ec50677aa2b0eecebe259aa4d3.tar.bz2
upstream-7f3facfce29639ec50677aa2b0eecebe259aa4d3.zip
firmware-utils: fix nec-enc build on older architectures
This patch enable gnu99 mode for the nec-enc utility which fixes the following build-breaking errors on some older architectures. nec-enc.c: In function ‘xor_data’: nec-enc.c:34:2: error: ‘for’ loop initial declarations are only allowed in C99 or C11 mode for (int i = 0; i < len; i++) { ^~~ nec-enc.c:34:2: note: use option -std=c99, -std=gnu99, -std=c11 or -std=gnu11 to compile your code nec-enc.c: In function ‘main’: nec-enc.c:101:3: error: ‘for’ loop initial declarations are only allowed in C99 or C11 mode for (int i = 0; i < n; i++) { ^~~ Spotted-By: Buildbot Fixes: fac27643f057 ("firmware-utils: add nec-enc") Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 7745b7bab2..76d5929af5 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -85,7 +85,7 @@ define Host/Compile
$(call cc,mkdlinkfw mkdlinkfw-lib, -lz -Wall --std=c99)
$(call cc,dns313-header, -Wall)
$(call cc,mksercommfw, -Wall)
- $(call cc,nec-enc, -Wall)
+ $(call cc,nec-enc, -Wall --std=gnu99)
endef
define Host/Install