aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2016-04-04 14:53:22 +0000
committerRafał Miłecki <zajec5@gmail.com>2016-04-04 14:53:22 +0000
commit27fbf299922a586a674cc3780d7824556b9fa053 (patch)
tree113ba10668769cec77c49377f987441262a3a035 /tools/firmware-utils/Makefile
parent3aca33cca3b1f2f74d07cfcfe20e7863b0be34eb (diff)
downloadupstream-27fbf299922a586a674cc3780d7824556b9fa053.tar.gz
upstream-27fbf299922a586a674cc3780d7824556b9fa053.tar.bz2
upstream-27fbf299922a586a674cc3780d7824556b9fa053.zip
firmware-utils: add oseama tool for creating Seama entities
It has an important feature (compared to seama) of using multiple input files, aligning them and padding zeroes until reaching a specified absolute offset. This is needed for a proper flash layout on NAND. We want kernel partition to be big enough to handle future updates without a need to resize it and wipe whole "ubi" partition. It's important as we don't want to lose block counters. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> Backport of r48601 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49116 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 6d88845ef6..0397845663 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -64,6 +64,7 @@ define Host/Compile
$(call cc,mkdapimg)
$(call cc, mkcameofw, -Wall)
$(call cc,seama md5)
+ $(call cc,oseama md5, -Wall)
$(call cc,fix-u-media-header cyg_crc32,-Wall)
$(call cc,hcsmakeimage bcmalgo)
$(call cc,mkporayfw, -Wall)