aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
author李国 <uxgood.org@gmail.com>2020-03-26 13:47:40 +0800
committerPetr Štetiar <ynezz@true.cz>2020-03-31 16:20:47 +0200
commit1963bbaa8f035c0a3c71233a049a7a4d7cd32711 (patch)
tree8671e7ecdf70c11e30286485b3a222b46c4fb859 /tools/firmware-utils/Makefile
parent332ed4a8354416ab64a9b510e5b2768c7fbb8c46 (diff)
downloadupstream-1963bbaa8f035c0a3c71233a049a7a4d7cd32711.tar.gz
upstream-1963bbaa8f035c0a3c71233a049a7a4d7cd32711.tar.bz2
upstream-1963bbaa8f035c0a3c71233a049a7a4d7cd32711.zip
firmware-utils: ptgen: add GPT support
Add GPT support to ptgen, so we can generate EFI bootable images. Introduced two options: -g generate GPT partition table -G GUID use GUID for disk and increase last bit for all partitions We drop The alternate partition table to reduce size, This may cause problems when generate vmdk images or vdi images. We have to pad enough sectors when generate these images. Signed-off-by: 李国 <uxgood.org@gmail.com> [fixed compilation on macOS] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 97c89eec27..561d6d868f 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -32,7 +32,7 @@ define Host/Compile
$(call cc,dgfirmware)
$(call cc,mksenaofw md5, -Wall --std=gnu99)
$(call cc,trx2usr)
- $(call cc,ptgen)
+ $(call cc,ptgen cyg_crc32)
$(call cc,srec2bin)
$(call cc,mkmylofw)
$(call cc,mkcsysimg)