aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorTal Keren <kooolk@gmail.com>2016-01-07 02:40:47 +0200
committerJo-Philipp Wich <jo@mein.io>2016-12-22 14:50:05 +0100
commit0d9d980ecd6fce5708003ed16c3238a680b1b16e (patch)
tree4fdf81d05143bd7d2b9ad891b9d72e106dd2fb30 /tools/firmware-utils/Makefile
parent87b0747263bdfdfd58eff6c8d772ba5d959692f4 (diff)
downloadupstream-0d9d980ecd6fce5708003ed16c3238a680b1b16e.tar.gz
upstream-0d9d980ecd6fce5708003ed16c3238a680b1b16e.tar.bz2
upstream-0d9d980ecd6fce5708003ed16c3238a680b1b16e.zip
firmware-utils: kernel image generator for TP-Link RE450
The firmware image that is used in TP-Link RE450 (and some more devices from the RE series) is tplink-safeloader. In the kernel partition, the kernel is compressed in a regular tp-link firmware that is just used for booting. Since it is only used for compressing and booting, only four fields are filled in the header: Vendor, version, kernel load address and kernel entry point. mktplinkfw-kernel is a simpler version of mktpolinkfw that generate such images. It also specifies the hardware id (as it is in the product info section), so when doing a sysupgrade - the existing code will check for hardware compatibility. Signed-off-by: Tal Keren <kooolk@gmail.com> [rd@radekdostal.com: add build target to .../image/tp-link.mk] Signed-off-by: Radek Dostál <rd@radekdostal.com>
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 456b7a39f5..69cba69a58 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -41,6 +41,7 @@ define Host/Compile
$(call cc,mkplanexfw sha1)
$(call cc,mktplinkfw md5, -Wall)
$(call cc,mktplinkfw2 md5)
+ $(call cc,mktplinkfw-kernel)
$(call cc,tplink-safeloader md5, -Wall)
$(call cc,pc1crypt)
$(call cc,osbridge-crc)