aboutsummaryrefslogtreecommitdiffstats
path: root/tools/firmware-utils/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2019-01-13 19:28:54 +0100
committerMathias Kresin <dev@kresin.me>2019-01-13 19:28:54 +0100
commit01e95dc0dc6620c0305cea16623c7b62ab3a7592 (patch)
tree71aa4f5892fc7ba99fbd5ed57994275d40a1f28f /tools/firmware-utils/Makefile
parent6a3f8b88185b2ee85bf7a33f6912508e7abcdef9 (diff)
downloadupstream-01e95dc0dc6620c0305cea16623c7b62ab3a7592.tar.gz
upstream-01e95dc0dc6620c0305cea16623c7b62ab3a7592.tar.bz2
upstream-01e95dc0dc6620c0305cea16623c7b62ab3a7592.zip
firmware-utils: mkdlinkfw: fix build
While we don't need the gnu99 option anymore, we still need to force the c99 standard to fix the following build error on the build bots: src/mkdlinkfw.c: In function 'find_auh_headers': src/mkdlinkfw.c:267:3: error: 'for' loop initial declarations are only allowed in C99 or C11 mode for (int i = 0; i < header_counter; i++) { ^ src/mkdlinkfw.c:267:3: note: use option -std=c99, -std=gnu99, -std=c11 or -std=gnu11 to compile your code Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'tools/firmware-utils/Makefile')
-rw-r--r--tools/firmware-utils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index a2f698622b..68782f3802 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -82,7 +82,7 @@ define Host/Compile
$(call cc,mkbuffaloimg, -Wall)
$(call cc,zyimage, -Wall)
$(call cc,mkdhpimg buffalo-lib, -Wall)
- $(call cc,mkdlinkfw mkdlinkfw-lib, -lz -Wall)
+ $(call cc,mkdlinkfw mkdlinkfw-lib, -lz -Wall --std=c99)
$(call cc,dns313-header, -Wall)
$(call cc,mksercommfw, -Wall --std=gnu99)
endef