aboutsummaryrefslogtreecommitdiffstats
path: root/tools/fakeroot
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2020-11-14 11:57:23 +0100
committerFelix Fietkau <nbd@nbd.name>2020-11-14 14:48:30 +0100
commit0fd214d89fa970b967c1aaf5613f145c869db2b1 (patch)
tree359bab421c369865dd98f194e6f3f8c1b8e70e32 /tools/fakeroot
parentcc16f5d73e770136eb0f3cf92ed518292d626bac (diff)
downloadupstream-0fd214d89fa970b967c1aaf5613f145c869db2b1.tar.gz
upstream-0fd214d89fa970b967c1aaf5613f145c869db2b1.tar.bz2
upstream-0fd214d89fa970b967c1aaf5613f145c869db2b1.zip
tools/fakeroot: fix build on macOS with recent Xcode versions
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/fakeroot')
-rw-r--r--tools/fakeroot/patches/100-portability.patch22
1 files changed, 21 insertions, 1 deletions
diff --git a/tools/fakeroot/patches/100-portability.patch b/tools/fakeroot/patches/100-portability.patch
index 3835a7792b..5713c9e3fe 100644
--- a/tools/fakeroot/patches/100-portability.patch
+++ b/tools/fakeroot/patches/100-portability.patch
@@ -25,7 +25,7 @@
#ifdef HAVE_SYS_ACL_H
#include <sys/acl.h>
#endif /* HAVE_SYS_ACL_H */
-@@ -1894,7 +1901,7 @@ ssize_t fremovexattr(int fd, const char
+@@ -1894,7 +1901,7 @@ ssize_t fremovexattr(int fd, const char
}
#endif /* HAVE_FREMOVEXATTR */
@@ -110,3 +110,23 @@
if(argname){
print "static __inline__ " ret " next_" name, argtype " __attribute__((always_inline));" > tmpffile;
print "static __inline__ " ret " next_" name, argtype " {" > tmpffile;
+--- a/configure.ac
++++ b/configure.ac
+@@ -110,6 +110,7 @@ for first in size_t int; do
+ #include <sys/types.h>
+ #endif
+ #include <unistd.h>
++#include <stdio.h>
+ #ifdef HAVE_GRP_H
+ #include <grp.h>
+ #endif
+--- a/configure
++++ b/configure
+@@ -12847,6 +12847,7 @@ for first in size_t int; do
+ #include <sys/types.h>
+ #endif
+ #include <unistd.h>
++#include <stdio.h>
+ #ifdef HAVE_GRP_H
+ #include <grp.h>
+ #endif