aboutsummaryrefslogtreecommitdiffstats
path: root/tools/ext2fs/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-07 00:04:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-07 00:04:25 +0000
commitc6bc77ea365704f3f5c79d64aed069792a4e95b1 (patch)
tree28c9265495e6ad751fcae0d27a040b222ff2a215 /tools/ext2fs/Makefile
parent9882253827b16579bbd317f6e8c0deb75b0ca0f3 (diff)
downloadupstream-c6bc77ea365704f3f5c79d64aed069792a4e95b1.tar.gz
upstream-c6bc77ea365704f3f5c79d64aed069792a4e95b1.tar.bz2
upstream-c6bc77ea365704f3f5c79d64aed069792a4e95b1.zip
build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail/openwrt-devel/2007-August/001159.html
SVN-Revision: 8362
Diffstat (limited to 'tools/ext2fs/Makefile')
-rw-r--r--tools/ext2fs/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/tools/ext2fs/Makefile b/tools/ext2fs/Makefile
index f10adbb6c3..69700ed54b 100644
--- a/tools/ext2fs/Makefile
+++ b/tools/ext2fs/Makefile
@@ -16,8 +16,6 @@ PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_MD5SUM:=664431bf6737df1c265500e1f0b5d40c
PKG_CAT:=zcat
-PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
include $(INCLUDE_DIR)/host-build.mk
define Build/Configure
@@ -43,17 +41,16 @@ endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
- CFLAGS="-O2 -I $(STAGING_DIR)/include-host -include getline.h" \
+ CFLAGS="$(HOST_CFLAGS) -include getline.h" \
all
endef
define Build/Install
- mkdir -p $(STAGING_DIR)/bin
- install -m0755 $(PKG_BUILD_DIR)/genext2fs $(STAGING_DIR)/bin/
+ install -m0755 $(PKG_BUILD_DIR)/genext2fs $(STAGING_DIR_HOST)/bin/
endef
define Build/Clean
- rm -f $(STAGING_DIR)/bin/genext2fs
+ rm -f $(STAGING_DIR_HOST)/bin/genext2fs
endef
$(eval $(call HostBuild))