aboutsummaryrefslogtreecommitdiffstats
path: root/tools/expat
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-07-18 22:50:11 +0200
committerJo-Philipp Wich <jo@mein.io>2017-07-18 23:00:45 +0200
commit7c727c6fa427dba9e43aaf3648d12af19a4858f1 (patch)
tree9b27628cb7e346025d7673e034a6b9455063b77f /tools/expat
parentb4ce088f06c5ee5c055f45361d03ac3ffcaaf2cf (diff)
downloadupstream-7c727c6fa427dba9e43aaf3648d12af19a4858f1.tar.gz
upstream-7c727c6fa427dba9e43aaf3648d12af19a4858f1.tar.bz2
upstream-7c727c6fa427dba9e43aaf3648d12af19a4858f1.zip
tools: expat: fix build on older host systems
Expat release 2.2.2 requires support for either syscall(SYS_getrandom) which is available on Linux 3.17 or support for getrandom() which is only available in glibc 2.25 or later. Since some of our builders still run on Linux 3.16, we need to forcibly disable the use of getrandom() for the host builds. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'tools/expat')
-rw-r--r--tools/expat/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/expat/Makefile b/tools/expat/Makefile
index 697d3f60d1..246089d609 100644
--- a/tools/expat/Makefile
+++ b/tools/expat/Makefile
@@ -18,6 +18,9 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+HOST_CONFIGURE_VARS += \
+ CPPFLAGS="$(HOST_CFLAGS) -DXML_POOR_ENTROPY"
+
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install
endef