aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2018-04-04 10:02:32 +0200
committerHans Dedecker <dedeckeh@gmail.com>2018-04-11 21:02:29 +0200
commita8c315192b750453e1b821ab735bdabca43a4d0e (patch)
tree652c014e0bdc95c00f12a3803267a4f9802c36d1 /tools/cmake
parentf6e6eadc99c6274207f8f2ebc739063549959a1f (diff)
downloadupstream-a8c315192b750453e1b821ab735bdabca43a4d0e.tar.gz
upstream-a8c315192b750453e1b821ab735bdabca43a4d0e.tar.bz2
upstream-a8c315192b750453e1b821ab735bdabca43a4d0e.zip
tools/cmake: Update to 3.11.0
Update cmake to 3.11.0 Remove 110-alpine_musl-compat.patch as it's integrated upstream Rename and refresh patches Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile6
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch4
-rw-r--r--tools/cmake/patches/110-alpine_musl-compat.patch16
-rw-r--r--tools/cmake/patches/110-libarchive-fix-libressl-compat.patch (renamed from tools/cmake/patches/120-libarchive-fix-libressl-compat.patch)0
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch (renamed from tools/cmake/patches/130-curl-fix-libressl-linking.patch)0
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch (renamed from tools/cmake/patches/140-bootstrap_parallel_make_flag.patch)2
6 files changed, 6 insertions, 22 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index f11b920611..8211c8d44b 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -7,13 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=3.10.1
+PKG_VERSION:=3.11.0
PKG_CPE_ID:=cpe:/a:kitware:cmake
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://cmake.org/files/v3.10/ \
+PKG_SOURCE_URL:=https://cmake.org/files/v3.11/ \
https://fossies.org/linux/misc/
-PKG_HASH:=7be36ee24b0f5928251b644d29f5ff268330a916944ef4a75e23ba01e7573284
+PKG_HASH:=c313bee371d4d255be2b4e96fd59b11d58bc550a7c78c021444ae565709a656b
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
index 6e8307dea4..46cdc94563 100644
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -1,6 +1,6 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -273,15 +273,6 @@ add_RunCMake_test(no_install_prefix)
+@@ -284,15 +284,6 @@ add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
add_RunCMake_test(CTestTimeoutAfterMatch)
@@ -18,7 +18,7 @@
add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -407,13 +407,6 @@ if(BUILD_TESTING)
+@@ -422,13 +422,6 @@ if(BUILD_TESTING)
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
diff --git a/tools/cmake/patches/110-alpine_musl-compat.patch b/tools/cmake/patches/110-alpine_musl-compat.patch
deleted file mode 100644
index a2c84fca4a..0000000000
--- a/tools/cmake/patches/110-alpine_musl-compat.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/Utilities/cmjsoncpp/include/json/assertions.h
-+++ b/Utilities/cmjsoncpp/include/json/assertions.h
-@@ -6,11 +6,12 @@
- #ifndef CPPTL_JSON_ASSERTIONS_H_INCLUDED
- #define CPPTL_JSON_ASSERTIONS_H_INCLUDED
-
-+#include <stdlib.h>
-+
- #if !defined(JSON_IS_AMALGAMATION)
- #include "config.h"
- #endif // if !defined(JSON_IS_AMALGAMATION)
-
--#include <stdlib.h>
- #include <sstream>
-
- /** It should not be possible for a maliciously designed file to
diff --git a/tools/cmake/patches/120-libarchive-fix-libressl-compat.patch b/tools/cmake/patches/110-libarchive-fix-libressl-compat.patch
index ba6565b6af..ba6565b6af 100644
--- a/tools/cmake/patches/120-libarchive-fix-libressl-compat.patch
+++ b/tools/cmake/patches/110-libarchive-fix-libressl-compat.patch
diff --git a/tools/cmake/patches/130-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index ad5b89750e..ad5b89750e 100644
--- a/tools/cmake/patches/130-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
diff --git a/tools/cmake/patches/140-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index a3cdefbb16..de5137ee38 100644
--- a/tools/cmake/patches/140-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -1,6 +1,6 @@
--- a/bootstrap
+++ b/bootstrap
-@@ -1130,7 +1130,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1149,7 +1149,10 @@ int main(){ printf("1%c", (char)0x0a); r
' > "test.c"
cmake_original_make_flags="${cmake_make_flags}"
if [ "x${cmake_parallel_make}" != "x" ]; then