aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2017-01-12 15:31:13 +0200
committerFelix Fietkau <nbd@nbd.name>2017-01-16 20:40:14 +0100
commit968fa531977f5d5b8ef8da83553f66d4a638cb51 (patch)
treec625b8dc730bf1d9e5839109c350f3d259961011 /tools/cmake
parent0d9f922230aa02821c538a87c1d10584cff6c61c (diff)
downloadupstream-968fa531977f5d5b8ef8da83553f66d4a638cb51.tar.gz
upstream-968fa531977f5d5b8ef8da83553f66d4a638cb51.tar.bz2
upstream-968fa531977f5d5b8ef8da83553f66d4a638cb51.zip
tools/cmake: remove HOST_CONFIGURE_CMD and re-distribute the args & vars
The final semantic is the same, but this is a bit more correct. Build tested on Windows 10 (yes, there is some Ubuntu mode for Windows 10, and I've been also building LEDE on it for a few weeks). Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index f3712391a6..d6f03e4208 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -19,15 +19,12 @@ HOST_CONFIGURE_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
-HOST_CONFIGURE_CMD := \
- MAKEFLAGS="$(HOST_JOBS)" \
- $(BASH) ./configure \
- $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
-
HOST_CONFIGURE_VARS += \
+ MAKEFLAGS="$(HOST_JOBS)" \
CXXFLAGS="$(HOST_CFLAGS)"
HOST_CONFIGURE_ARGS := \
+ $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)") \
--prefix=$(STAGING_DIR_HOST)
ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)