aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2018-12-29 17:27:20 +0100
committerHans Dedecker <dedeckeh@gmail.com>2018-12-29 18:12:28 +0100
commit77429a820f8efff25c8e3c3e3579f636eff58fbc (patch)
tree9c5149c1a9a8f1706d64f2d5271e39ae2d56745f /tools/cmake
parent335c69fbb21a21c9286f02d59fb40dc0a3e38c07 (diff)
downloadupstream-77429a820f8efff25c8e3c3e3579f636eff58fbc.tar.gz
upstream-77429a820f8efff25c8e3c3e3579f636eff58fbc.tar.bz2
upstream-77429a820f8efff25c8e3c3e3579f636eff58fbc.zip
tools/cmake: update to 3.13.2
Update to the latest stable version and refresh patches; see https://cmake.org/cmake/help/v3.13/release/3.13.html for the latest changes in 3.13.x Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile6
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch4
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch4
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch2
4 files changed, 8 insertions, 8 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 087411013b..888cf7de8e 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -7,13 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=3.12.4
+PKG_VERSION:=3.13.2
PKG_CPE_ID:=cpe:/a:kitware:cmake
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://cmake.org/files/v3.12/ \
+PKG_SOURCE_URL:=https://cmake.org/files/v3.13/ \
https://fossies.org/linux/misc/
-PKG_HASH:=5255584bfd043eb717562cff8942d472f1c0e4679c4941d84baadaa9b28e3194
+PKG_HASH:=c925e7d2c5ba511a69f43543ed7b4182a7d446c274c7480d0e42cd933076ae25
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
index a354e1cac1..af04bf7c41 100644
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -1,6 +1,6 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -290,15 +290,6 @@ add_RunCMake_test(no_install_prefix)
+@@ -301,15 +301,6 @@ add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
add_RunCMake_test(CTestTimeoutAfterMatch)
@@ -18,7 +18,7 @@
add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -435,13 +435,6 @@ if(BUILD_TESTING)
+@@ -437,13 +437,6 @@ if(BUILD_TESTING)
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
diff --git a/tools/cmake/patches/120-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index 20c5052cce..e217979ee4 100644
--- a/tools/cmake/patches/120-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
@@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -452,6 +452,14 @@ if(CMAKE_USE_OPENSSL)
+@@ -454,6 +454,14 @@ if(CMAKE_USE_OPENSSL)
set(USE_OPENSSL ON)
set(HAVE_LIBCRYPTO ON)
set(HAVE_LIBSSL ON)
@@ -34,4 +34,4 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
+ endif()
list(APPEND CURL_LIBS ${OPENSSL_LIBRARIES})
include_directories(${OPENSSL_INCLUDE_DIR})
- set(CMAKE_REQUIRED_INCLUDES ${OPENSSL_INCLUDE_DIR})
+
diff --git a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index 375bc5d979..535417d55a 100644
--- a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -1,6 +1,6 @@
--- a/bootstrap
+++ b/bootstrap
-@@ -1163,7 +1163,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1164,7 +1164,10 @@ int main(){ printf("1%c", (char)0x0a); r
' > "test.c"
cmake_original_make_flags="${cmake_make_flags}"
if [ "x${cmake_parallel_make}" != "x" ]; then