aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-10-02 13:56:50 +0200
committerJo-Philipp Wich <jo@mein.io>2017-10-02 14:00:48 +0200
commit64da598c8f8bc3002ae2e8f90f0cf20986493348 (patch)
treecb0c605a017c1ff96172e9f9b9bf3e18135457a4 /tools/cmake
parent5508510e744ce9dfaba23cb8639977f021bd29f9 (diff)
downloadupstream-64da598c8f8bc3002ae2e8f90f0cf20986493348.tar.gz
upstream-64da598c8f8bc3002ae2e8f90f0cf20986493348.tar.bz2
upstream-64da598c8f8bc3002ae2e8f90f0cf20986493348.zip
tools: cmake: fix librt linking (FS#1032)
Commit 839129b864 "tools/cmake: Update to 3.9.3" improperly rebased the librt linking patch, causing FS#381 to resurface. Fixes FS#1032. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/patches/130-curl-fix-libressl-linking.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/tools/cmake/patches/130-curl-fix-libressl-linking.patch b/tools/cmake/patches/130-curl-fix-libressl-linking.patch
index 1a15ff47af..b5ee61b58a 100644
--- a/tools/cmake/patches/130-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/130-curl-fix-libressl-linking.patch
@@ -20,14 +20,14 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -471,6 +471,10 @@ if(CMAKE_USE_OPENSSL)
- check_symbol_exists(RAND_status "${CURL_INCLUDES}" HAVE_RAND_STATUS)
- check_symbol_exists(RAND_screen "${CURL_INCLUDES}" HAVE_RAND_SCREEN)
- check_symbol_exists(RAND_egd "${CURL_INCLUDES}" HAVE_RAND_EGD)
+@@ -456,6 +456,10 @@ if(CMAKE_USE_OPENSSL)
+ set(USE_OPENSSL ON)
+ set(HAVE_LIBCRYPTO ON)
+ set(HAVE_LIBSSL ON)
+ check_library_exists("rt" clock_gettime "" HAVE_LIBRT)
+ if(HAVE_LIBRT)
+ list(APPEND OPENSSL_LIBRARIES rt)
+ endif()
-
- # Optionally build with a specific CA cert bundle.
- if(CURL_CA_BUNDLE)
+ list(APPEND CURL_LIBS ${OPENSSL_LIBRARIES})
+ include_directories(${OPENSSL_INCLUDE_DIR})
+ set(CMAKE_REQUIRED_INCLUDES ${OPENSSL_INCLUDE_DIR})