aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2016-11-25 16:10:09 +0200
committerJohn Crispin <john@phrozen.org>2016-11-26 21:59:40 +0100
commit2c05fd7ef429cd4f10f44adf604bbc814b189c6b (patch)
treef0762ddd1bc14b865a3854cd54b40166239b0026 /tools/cmake
parenta22464b92f2eedb7951237e0d8d505188d32ddc0 (diff)
downloadupstream-2c05fd7ef429cd4f10f44adf604bbc814b189c6b.tar.gz
upstream-2c05fd7ef429cd4f10f44adf604bbc814b189c6b.tar.bz2
upstream-2c05fd7ef429cd4f10f44adf604bbc814b189c6b.zip
tools/cmake: update to 3.7.0
Release notes at https://cmake.org/cmake/help/v3.7/release/3.7.html Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile6
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch4
-rw-r--r--tools/cmake/patches/110-freebsd-compat.patch2
3 files changed, 6 insertions, 6 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 7de0bd8183..489c27f1d8 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=3.6.1
+PKG_VERSION:=3.7.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://cmake.org/files/v3.6/ \
+PKG_SOURCE_URL:=https://cmake.org/files/v3.7/ \
https://fossies.org/linux/misc/
-PKG_MD5SUM:=d6dd661380adacdb12f41b926ec99545
+PKG_MD5SUM:=3801dc4e54c1c957a7378d8b0d4254ba
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
index a4c7b7e795..6f28c435e0 100644
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -1,6 +1,6 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -219,15 +219,6 @@ add_RunCMake_test(no_install_prefix)
+@@ -225,15 +225,6 @@ add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
add_RunCMake_test(CTestTimeoutAfterMatch)
@@ -18,7 +18,7 @@
add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -392,10 +392,6 @@ if(BUILD_TESTING)
+@@ -393,10 +393,6 @@ if(BUILD_TESTING)
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
diff --git a/tools/cmake/patches/110-freebsd-compat.patch b/tools/cmake/patches/110-freebsd-compat.patch
index b7419d0bb5..c1d4a274d6 100644
--- a/tools/cmake/patches/110-freebsd-compat.patch
+++ b/tools/cmake/patches/110-freebsd-compat.patch
@@ -36,4 +36,4 @@ Change-Id: I3b91ed7ac0e6878035aee202b3336c536cc6d2ff
+# endif
#endif
- #if defined(__OpenBSD__) || defined(__NetBSD__)
+ #if defined(KWSYS_SYS_HAS_MACHINE_CPU_H)