aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2017-05-08 22:18:25 +0300
committerFelix Fietkau <nbd@nbd.name>2017-05-25 19:01:07 +0200
commit1a0d52a733df1467c4b76c42a9612a8ab8c0c63a (patch)
tree31252c34a210df3c9a1b799a1d96b40ae65a440d /tools/cmake
parent910df3f06cc902ca2cb0ca8e963e9354c930df1a (diff)
downloadupstream-1a0d52a733df1467c4b76c42a9612a8ab8c0c63a.tar.gz
upstream-1a0d52a733df1467c4b76c42a9612a8ab8c0c63a.tar.bz2
upstream-1a0d52a733df1467c4b76c42a9612a8ab8c0c63a.zip
tools/cmake: update to 3.8.1
* update cmake to 3.8.1 * refresh patches Release notes: https://cmake.org/cmake/help/v3.8/release/3.8.html Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile6
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch4
-rw-r--r--tools/cmake/patches/110-freebsd-compat.patch8
-rw-r--r--tools/cmake/patches/140-curl-fix-libressl-linking.patch2
-rw-r--r--tools/cmake/patches/150-bootstrap_parallel_make_flag.patch2
5 files changed, 11 insertions, 11 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index cd9e7c16fc..a94942f84c 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=3.7.2
+PKG_VERSION:=3.8.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://cmake.org/files/v3.7/ \
+PKG_SOURCE_URL:=https://cmake.org/files/v3.8/ \
https://fossies.org/linux/misc/
-PKG_HASH:=dc1246c4e6d168ea4d6e042cfba577c1acd65feea27e56f5ff37df920c30cae0
+PKG_HASH:=ce5d9161396e06501b00e52933783150a87c33080d4bdcef461b5b7fd24ac228
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
index 6f28c435e0..54a75bc776 100644
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -1,6 +1,6 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -225,15 +225,6 @@ add_RunCMake_test(no_install_prefix)
+@@ -244,15 +244,6 @@ add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
add_RunCMake_test(CTestTimeoutAfterMatch)
@@ -18,7 +18,7 @@
add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -393,10 +393,6 @@ if(BUILD_TESTING)
+@@ -398,10 +398,6 @@ if(BUILD_TESTING)
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
diff --git a/tools/cmake/patches/110-freebsd-compat.patch b/tools/cmake/patches/110-freebsd-compat.patch
index c1d4a274d6..4f11078461 100644
--- a/tools/cmake/patches/110-freebsd-compat.patch
+++ b/tools/cmake/patches/110-freebsd-compat.patch
@@ -21,10 +21,10 @@ Change-Id: I3b91ed7ac0e6878035aee202b3336c536cc6d2ff
--- a/Source/kwsys/SystemInformation.cxx
+++ b/Source/kwsys/SystemInformation.cxx
-@@ -89,6 +89,15 @@ typedef int siginfo_t;
- # include <ifaddrs.h>
- # define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
- # endif
+@@ -82,6 +82,15 @@ typedef int siginfo_t;
+ #include <net/if.h>
+ #define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
+ #endif
+# if defined(KWSYS_SYSTEMINFORMATION_HAS_BACKTRACE)
+# include <execinfo.h>
+# if defined(KWSYS_SYSTEMINFORMATION_HAS_CPP_DEMANGLE)
diff --git a/tools/cmake/patches/140-curl-fix-libressl-linking.patch b/tools/cmake/patches/140-curl-fix-libressl-linking.patch
index 5b57172eb4..c16e927ff3 100644
--- a/tools/cmake/patches/140-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/140-curl-fix-libressl-linking.patch
@@ -19,7 +19,7 @@ and unconditionally link the rt library when the symbol is found.
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -362,6 +362,10 @@ set(HAVE_LIBSSL OFF)
+@@ -374,6 +374,10 @@ set(HAVE_LIBSSL OFF)
if(CMAKE_USE_OPENSSL)
find_package(OpenSSL)
if(OPENSSL_FOUND)
diff --git a/tools/cmake/patches/150-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/150-bootstrap_parallel_make_flag.patch
index 6970b83b32..4d432dcc1e 100644
--- a/tools/cmake/patches/150-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/150-bootstrap_parallel_make_flag.patch
@@ -1,6 +1,6 @@
--- a/bootstrap
+++ b/bootstrap
-@@ -958,7 +958,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1046,7 +1046,10 @@ int main(){ printf("1%c", (char)0x0a); r
' > "test.c"
cmake_original_make_flags="${cmake_make_flags}"
if [ "x${cmake_parallel_make}" != "x" ]; then