aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-05 14:31:28 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-05 14:34:11 +0100
commit08d73bfdce36e4cbb6e2d3c2ef9073925ac8e7c8 (patch)
treebe3eb2995e424db68f9c52bf16daa89b5eb1a95e /tools/cmake
parent267b05f273f9e2d48933d0e9866bfe7d6e28ee43 (diff)
downloadupstream-08d73bfdce36e4cbb6e2d3c2ef9073925ac8e7c8.tar.gz
upstream-08d73bfdce36e4cbb6e2d3c2ef9073925ac8e7c8.tar.bz2
upstream-08d73bfdce36e4cbb6e2d3c2ef9073925ac8e7c8.zip
tools: cmake: use different approach for passing LDFLAGS
Funnel the required LDFLAGS environment through HOST_CONFIGURE_CMD for now as the HOST_CONFIGURE_VARS semantics are completely broken. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'tools/cmake')
-rw-r--r--tools/cmake/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 13390ab967..6214da748b 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -19,10 +19,12 @@ HOST_CONFIGURE_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
-HOST_CONFIGURE_CMD := MAKEFLAGS="$(HOST_JOBS)" $(BASH) ./configure
+HOST_CONFIGURE_CMD := \
+ MAKEFLAGS="$(HOST_JOBS)" \
+ LDFLAGS="$$$$(pkg-config --static --libs libcrypto)" \
+ $(BASH) ./configure
-HOST_CONFIGURE_VARS := \
- LDFLAGS="$$$$(pkg-config --static --libs libcrypto)"
+HOST_CONFIGURE_VARS :=
HOST_CONFIGURE_ARGS := \
--prefix=$(STAGING_DIR_HOST)