aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2019-03-17 11:17:28 +0100
committerStijn Tintel <stijn@linux-ipv6.be>2019-03-17 11:25:50 +0100
commitd4540354303949c93b20ea0148afd90ce5e40ea6 (patch)
treefbf3bda101d1380015ec8f64efee52b38907eca5 /tools/cmake/patches
parenta56c21f582810a28e9493dcfae584132d7ea9451 (diff)
downloadupstream-d4540354303949c93b20ea0148afd90ce5e40ea6.tar.gz
upstream-d4540354303949c93b20ea0148afd90ce5e40ea6.tar.bz2
upstream-d4540354303949c93b20ea0148afd90ce5e40ea6.zip
Revert "tools/cmake: Update to 3.14.0"
The cmake bump to 3.14.0 breaks build on all targets. Revert it for now. This reverts commit a3446257a8737bfc2899c5911791873561feecc7. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'tools/cmake/patches')
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch4
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch2
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch2
-rw-r--r--tools/cmake/patches/150-C-feature-checks-Match-warnings-more-strictly.patch25
4 files changed, 29 insertions, 4 deletions
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
index 7f83e279f7..af04bf7c41 100644
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -1,6 +1,6 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -325,15 +325,6 @@ add_RunCMake_test(no_install_prefix)
+@@ -301,15 +301,6 @@ add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
add_RunCMake_test(CTestTimeoutAfterMatch)
@@ -18,7 +18,7 @@
add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -483,13 +483,6 @@ if(BUILD_TESTING)
+@@ -437,13 +437,6 @@ if(BUILD_TESTING)
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
diff --git a/tools/cmake/patches/120-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index e7d9c5ddda..e217979ee4 100644
--- a/tools/cmake/patches/120-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
@@ -20,7 +20,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -453,6 +453,14 @@ if(CMAKE_USE_OPENSSL)
+@@ -454,6 +454,14 @@ if(CMAKE_USE_OPENSSL)
set(USE_OPENSSL ON)
set(HAVE_LIBCRYPTO ON)
set(HAVE_LIBSSL ON)
diff --git a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index 124cf6d9d4..535417d55a 100644
--- a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -1,6 +1,6 @@
--- a/bootstrap
+++ b/bootstrap
-@@ -1168,7 +1168,10 @@ int main(){ printf("1%c", (char)0x0a); r
+@@ -1164,7 +1164,10 @@ int main(){ printf("1%c", (char)0x0a); r
' > "test.c"
cmake_original_make_flags="${cmake_make_flags}"
if [ "x${cmake_parallel_make}" != "x" ]; then
diff --git a/tools/cmake/patches/150-C-feature-checks-Match-warnings-more-strictly.patch b/tools/cmake/patches/150-C-feature-checks-Match-warnings-more-strictly.patch
new file mode 100644
index 0000000000..674ff0d392
--- /dev/null
+++ b/tools/cmake/patches/150-C-feature-checks-Match-warnings-more-strictly.patch
@@ -0,0 +1,25 @@
+From 4ca5a815f2dfe9e1116cc2ccd5ddb56d0d00d12e Mon Sep 17 00:00:00 2001
+From: Brad King <brad.king@kitware.com>
+Date: Thu, 7 Mar 2019 14:55:54 -0500
+Subject: [PATCH] C++ feature checks: Match warnings more strictly
+
+Require the word "warning" to appear at the start of a line, after
+whitespace, or after a `:`. This is the same that CTest launchers use
+to match warnings. It avoids matching "warning" inside file paths.
+
+Fixes: #19019
+---
+ Source/Checks/cm_cxx_features.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/Source/Checks/cm_cxx_features.cmake
++++ b/Source/Checks/cm_cxx_features.cmake
+@@ -25,7 +25,7 @@ function(cm_check_cxx_feature name)
+ # Filter out xcodebuild warnings.
+ string(REGEX REPLACE "[^\n]* xcodebuild\\[[0-9]*:[0-9]*\\] warning: [^\n]*" "" check_output "${check_output}")
+ # If using the feature causes warnings, treat it as broken/unavailable.
+- if(check_output MATCHES "[Ww]arning")
++ if(check_output MATCHES "(^|[ :])[Ww][Aa][Rr][Nn][Ii][Nn][Gg]")
+ set(CMake_HAVE_CXX_${FEATURE} OFF CACHE INTERNAL "TRY_COMPILE" FORCE)
+ endif()
+ if(CMake_HAVE_CXX_${FEATURE})