aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-31 09:31:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-31 09:31:06 +0000
commit35cc181eb2b0e6ecf20412e3d117b1fcec96628b (patch)
treed59ed221eada35dbd1a491ff239994c3d1d29e2e /tools/cmake/patches
parentfaabe8e8e60f6100bf7611800676973928e8cced (diff)
downloadupstream-35cc181eb2b0e6ecf20412e3d117b1fcec96628b.tar.gz
upstream-35cc181eb2b0e6ecf20412e3d117b1fcec96628b.tar.bz2
upstream-35cc181eb2b0e6ecf20412e3d117b1fcec96628b.zip
tools/cmake: update to 3.3.2
Update cmake to 3.3.2 and refresh patches. Add a secondary download location. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> SVN-Revision: 47327
Diffstat (limited to 'tools/cmake/patches')
-rw-r--r--tools/cmake/patches/100-disable_qt_tests.patch19
-rw-r--r--tools/cmake/patches/110-freebsd-compat.patch4
2 files changed, 10 insertions, 13 deletions
diff --git a/tools/cmake/patches/100-disable_qt_tests.patch b/tools/cmake/patches/100-disable_qt_tests.patch
index 3d44dac53f..deaa5ae48c 100644
--- a/tools/cmake/patches/100-disable_qt_tests.patch
+++ b/tools/cmake/patches/100-disable_qt_tests.patch
@@ -1,8 +1,8 @@
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -101,16 +101,6 @@
- add_RunCMake_test(TargetPolicies)
- add_RunCMake_test(alias_targets)
+@@ -160,15 +160,6 @@
+ add_RunCMake_test(no_install_prefix)
+ add_RunCMake_test(configure_file)
-find_package(Qt4 QUIET)
-find_package(Qt5Core QUIET)
@@ -10,21 +10,20 @@
- add_RunCMake_test(IncompatibleQt)
-endif()
-if (QT4_FOUND)
-- set(ObsoleteQtMacros_ARGS -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE})
-- add_RunCMake_test(ObsoleteQtMacros)
+- add_RunCMake_test(ObsoleteQtMacros -DQT_QMAKE_EXECUTABLE:FILEPATH=${QT_QMAKE_EXECUTABLE})
-endif()
-
- if("${CMAKE_TEST_GENERATOR}" MATCHES "Visual Studio [^6]")
- add_RunCMake_test(include_external_msproject)
- add_RunCMake_test(SolutionGlobalSections)
+ find_package(PkgConfig QUIET)
+ if(PKG_CONFIG_FOUND)
+ add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -262,10 +262,6 @@
+@@ -358,10 +358,6 @@
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
- if(NOT QT4_FOUND)
-- find_package(Qt4)
+- find_package(Qt4 QUIET)
- endif()
-
if(QT4_FOUND)
diff --git a/tools/cmake/patches/110-freebsd-compat.patch b/tools/cmake/patches/110-freebsd-compat.patch
index d4133b9049..9133db5038 100644
--- a/tools/cmake/patches/110-freebsd-compat.patch
+++ b/tools/cmake/patches/110-freebsd-compat.patch
@@ -23,7 +23,7 @@ diff --git a/Source/kwsys/SystemInformation.cxx b/Source/kwsys/SystemInformation
index 7c31f3a..2672730 100644
--- a/Source/kwsys/SystemInformation.cxx
+++ b/Source/kwsys/SystemInformation.cxx
-@@ -88,6 +88,15 @@ typedef int siginfo_t;
+@@ -91,6 +91,15 @@ typedef int siginfo_t;
# include <ifaddrs.h>
# define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
# endif
@@ -39,6 +39,4 @@ index 7c31f3a..2672730 100644
#endif
#if defined(__OpenBSD__) || defined(__NetBSD__)
---
-1.7.10.4