aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/patches/120-curl-fix-libressl-linking.patch
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2020-08-23 17:11:11 +0300
committerHans Dedecker <dedeckeh@gmail.com>2020-08-23 19:40:42 +0200
commit84834df9b9867b37b1ac6ade8abcf17cda456974 (patch)
treee0833c77fa8c9d1e73dd35bc5fc22dfbb0729c5f /tools/cmake/patches/120-curl-fix-libressl-linking.patch
parent4faf7704a2426c1b93262473d547e38fa067c356 (diff)
downloadupstream-84834df9b9867b37b1ac6ade8abcf17cda456974.tar.gz
upstream-84834df9b9867b37b1ac6ade8abcf17cda456974.tar.bz2
upstream-84834df9b9867b37b1ac6ade8abcf17cda456974.zip
tools/cmake: update to 3.18.2
Update cmake to version 3.18.2. Refresh patches. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'tools/cmake/patches/120-curl-fix-libressl-linking.patch')
-rw-r--r--tools/cmake/patches/120-curl-fix-libressl-linking.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/cmake/patches/120-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
index 66e3f81c6f..4fb541f3e4 100644
--- a/tools/cmake/patches/120-curl-fix-libressl-linking.patch
+++ b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
@@ -20,10 +20,10 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
--- a/Utilities/cmcurl/CMakeLists.txt
+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -459,6 +459,14 @@ if(CMAKE_USE_OPENSSL)
+@@ -488,6 +488,14 @@ if(CMAKE_USE_OPENSSL)
+ endif()
+ set(SSL_ENABLED ON)
set(USE_OPENSSL ON)
- set(HAVE_LIBCRYPTO ON)
- set(HAVE_LIBSSL ON)
+ check_library_exists("rt" clock_gettime "" HAVE_LIBRT)
+ if(HAVE_LIBRT)
+ list(APPEND OPENSSL_LIBRARIES rt)