aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-11 03:41:10 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-11 03:48:30 +0100
commit43d53399406b08bdfeb78727cd122578aee4894a (patch)
tree0120937b8abc3d101cba4304a6d7f5e442108548 /tools/cmake/Makefile
parent69be65b594c4fafbc4e58dd3cd235547f02a33ca (diff)
downloadupstream-43d53399406b08bdfeb78727cd122578aee4894a.tar.gz
upstream-43d53399406b08bdfeb78727cd122578aee4894a.tar.bz2
upstream-43d53399406b08bdfeb78727cd122578aee4894a.zip
tools: cmake: link librt if needed (FS#381)
Patch cmakes cmcurl component to unconditionally link librt when we discover a clock_gettime() symbol in -lrt. This is required to sucessfully link LibreSSL's libcrypto which might or might not reqauire librt. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'tools/cmake/Makefile')
-rw-r--r--tools/cmake/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 6214da748b..a1137c5b50 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -20,9 +20,7 @@ HOST_CONFIGURE_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_CMD := \
- MAKEFLAGS="$(HOST_JOBS)" \
- LDFLAGS="$$$$(pkg-config --static --libs libcrypto)" \
- $(BASH) ./configure
+ MAKEFLAGS="$(HOST_JOBS)" $(BASH) ./configure
HOST_CONFIGURE_VARS :=