aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cmake/Makefile
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2019-03-16 21:09:22 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2019-09-01 18:38:05 +0200
commit413c68d120043cd8ff1f4aa057d33c140bfc6bfa (patch)
tree83890d5a974042f8f2d5f3cb6d1d36c753bcf78f /tools/cmake/Makefile
parentb74f1f335a792a15feb0fd839a69486050d3531f (diff)
downloadupstream-413c68d120043cd8ff1f4aa057d33c140bfc6bfa.tar.gz
upstream-413c68d120043cd8ff1f4aa057d33c140bfc6bfa.tar.bz2
upstream-413c68d120043cd8ff1f4aa057d33c140bfc6bfa.zip
tools/cmake: Update to 3.15.1
Update CMake to 3.15.1 Refresh patches Remove inofficial fossies.org and replace with GitHub (link on official site) Remove 150-C-feature-checks-Match-warnings-more-strictly.patch as it's a no longer needed backport from upstream. Disable ccache if GCC is 4.8, 4.9 or 5.X to avoid build failures. Reference: https://github.com/openwrt/openwrt/pull/1929 Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'tools/cmake/Makefile')
-rw-r--r--tools/cmake/Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 888cf7de8e..33d6d4944f 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -7,19 +7,33 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=3.13.2
+PKG_VERSION:=3.15.1
PKG_CPE_ID:=cpe:/a:kitware:cmake
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://cmake.org/files/v3.13/ \
- https://fossies.org/linux/misc/
-PKG_HASH:=c925e7d2c5ba511a69f43543ed7b4182a7d446c274c7480d0e42cd933076ae25
+PKG_SOURCE_URL:=https://github.com/Kitware/CMake/releases/download/v$(PKG_VERSION)/ \
+ https://cmake.org/files/v3.15/
+PKG_HASH:=18dec548d8f8b04d53c60f9cedcebaa6762f8425339d1e2c889c383d3ccdd7f7
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+# Workaround for GCC versions below 6.X and ccache
+# Reference: https://github.com/openwrt/openwrt/pull/1929
+GCC_DMPVER_GREPCMD := grep -E '^(4\.[8-9]|[5]\.?)'
+GCC_DMPVER_STRING := $(shell $(HOSTCC_NOCACHE) -dumpversion | $(GCC_DMPVER_GREPCMD))
+ifneq ($(GCC_DMPVER_STRING),)
+ ifeq ($(CONFIG_CCACHE),y)
+ $(info GCC version less than 6.0 detected, disabling CCACHE)
+ HOST_CONFIGURE_VARS:=$(filter-out CC=% gcc%",$(HOST_CONFIGURE_VARS)) CC="$(HOSTCC_NOCACHE)"
+ HOST_CONFIGURE_VARS:=$(filter-out CXX=% g++%",$(HOST_CONFIGURE_VARS)) CXX="$(HOSTCXX_NOCACHE)"
+ else
+ $(info GCC version greater or equal to 6.0 detected, no workaround set for CCACHE)
+ endif
+endif
+
HOST_CONFIGURE_VARS += \
MAKEFLAGS="$(HOST_JOBS)" \
CXXFLAGS="$(HOST_CFLAGS)"