aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cbootimage
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-04-01 19:25:39 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-04-06 14:48:46 +0200
commit8595bb0b17e62c2e1badfc64aab5ea5703e22bb9 (patch)
tree2dc05ef6a7af5a601e4c3e3909e204c2466d4bdd /tools/cbootimage
parent42f96ed9413a3483b0448581374feeb3343f6f6a (diff)
downloadupstream-8595bb0b17e62c2e1badfc64aab5ea5703e22bb9.tar.gz
upstream-8595bb0b17e62c2e1badfc64aab5ea5703e22bb9.tar.bz2
upstream-8595bb0b17e62c2e1badfc64aab5ea5703e22bb9.zip
tools: add cbootimage for tegra
Tegra BCT and bootable flash image generator/compiler >From documentation: This project provides a tool which compiles BCT (Boot Configuration Table) images to place into the boot flash of a Tegra-based device. The tool will either: a) Compile a textual representation of a BCT into a binary image. b) Generate an entire boot image from a previously compiled BCT and a bootloader binary. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'tools/cbootimage')
-rw-r--r--tools/cbootimage/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/tools/cbootimage/Makefile b/tools/cbootimage/Makefile
new file mode 100644
index 0000000000..42640eab36
--- /dev/null
+++ b/tools/cbootimage/Makefile
@@ -0,0 +1,31 @@
+#
+# Copyright (c) 2017-2019 Tomasz Maciej Nowak <tomek_n@o2.pl>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME := cbootimage
+PKG_VERSION := 1.8
+
+PKG_SOURCE_PROTO := git
+PKG_SOURCE_URL := https://github.com/NVIDIA/cbootimage.git
+PKG_SOURCE_VERSION := 7c9db585d06cce9efffa2a82245f233233680060
+PKG_MIRROR_HASH := 84d9abaaa3eddde05f506dc16effe1c9e18eb94727ed59c5e0a879baeb04e0b2
+
+HOST_BUILD_PARALLEL := 1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); autoreconf --install --symlink)
+ $(call Host/Configure/Default)
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/$(PKG_NAME) \
+ $(STAGING_DIR_HOST)/share/man/man1/$(PKG_NAME).1
+endef
+
+$(eval $(call HostBuild))