aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cbootimage-configs
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-04-01 19:25:40 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-04-06 14:48:46 +0200
commitb8744376445692062c7d4e59a9814dc70c76a88d (patch)
treee2347785bbccdefe744f1f63dd18e595760fe658 /tools/cbootimage-configs
parent8595bb0b17e62c2e1badfc64aab5ea5703e22bb9 (diff)
downloadupstream-b8744376445692062c7d4e59a9814dc70c76a88d.tar.gz
upstream-b8744376445692062c7d4e59a9814dc70c76a88d.tar.bz2
upstream-b8744376445692062c7d4e59a9814dc70c76a88d.zip
tools: add cbootimage-configs for tegra
This provides board configuraion tables for various Tegra boards needed by cbootimage tool to create flashable bootloader images. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'tools/cbootimage-configs')
-rw-r--r--tools/cbootimage-configs/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/tools/cbootimage-configs/Makefile b/tools/cbootimage-configs/Makefile
new file mode 100644
index 0000000000..5a1fc568cb
--- /dev/null
+++ b/tools/cbootimage-configs/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (c) 2017-2019 Tomasz Maciej Nowak <tomek_n@o2.pl>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME := cbootimage-configs
+
+PKG_SOURCE_DATE := 2017-04-13
+PKG_SOURCE_PROTO := git
+PKG_SOURCE_URL := https://github.com/NVIDIA/cbootimage-configs.git
+PKG_SOURCE_VERSION := 7c3b458b93ed6947cd083623f543e93f9103cc0f
+PKG_MIRROR_HASH := 1d24421af8cf74ec2d625e237aa8121b1273774c4380ad333e2954e052a5a4fe
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+endef
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/$(PKG_NAME)
+ $(CP) $(HOST_BUILD_DIR)/* \
+ $(STAGING_DIR_HOST)/share/$(PKG_NAME)
+endef
+
+define Host/Clean
+ rm -fR $(STAGING_DIR_HOST)/share/$(PKG_NAME)
+endef
+
+$(eval $(call HostBuild))