aboutsummaryrefslogtreecommitdiffstats
path: root/tools/automake/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-03-24 13:13:01 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-03-24 13:13:01 +0000
commitf6c581cc3ef85ee1b26a02456bcbf0bf52438a23 (patch)
treefd34e7194a79f4b18fb25f2136535c7a47b72162 /tools/automake/Makefile
parente0c8e20f8c0765f58707439057405d0eb946746c (diff)
downloadupstream-f6c581cc3ef85ee1b26a02456bcbf0bf52438a23.tar.gz
upstream-f6c581cc3ef85ee1b26a02456bcbf0bf52438a23.tar.bz2
upstream-f6c581cc3ef85ee1b26a02456bcbf0bf52438a23.zip
automake: portability fixes
The rework of the host tools discovery caused automake to embed absolute paths to staging_dir/host/bin/perl into the shebang of the generated automake executables. Switch to the portable "/usr/bin/env perl" and enable global warnings through "$^W" instead of the "-w" interpreter argument. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44972
Diffstat (limited to 'tools/automake/Makefile')
-rw-r--r--tools/automake/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index 6395d84387..0eea101983 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -19,7 +19,9 @@ HOST_CONFIGURE_ARGS += \
--datarootdir=$(STAGING_DIR_HOST)/share \
--disable-silent-rules
-HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
+HOST_CONFIGURE_VARS += \
+ PERL="/usr/bin/env perl" \
+ am_cv_prog_PERL_ithreads=no
define Host/Configure
(cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR="" ./bootstrap.sh)