aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-06-12 14:24:40 +0200
committerFelix Fietkau <nbd@nbd.name>2021-06-12 14:33:57 +0200
commitfa0aea53b2f1dccc2073efac8020151960d25513 (patch)
tree109c4bb3b6c599a74677f96346ad200ff7c24a03 /tools/Makefile
parentd45baa860ffc79ae1cf68fceb94990e39bb06bab (diff)
downloadupstream-fa0aea53b2f1dccc2073efac8020151960d25513.tar.gz
upstream-fa0aea53b2f1dccc2073efac8020151960d25513.tar.bz2
upstream-fa0aea53b2f1dccc2073efac8020151960d25513.zip
tools: build ninja before ccache to fix the build order
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index dccf298af6..a48aa80db3 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -79,7 +79,7 @@ ifneq ($(HOST_OS),Linux)
endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(filter-out xz zstd patch pkgconf libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
+$(foreach tool, $(filter-out xz zstd patch pkgconf libressl ninja cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
tools-y += ccache
$(curdir)/ccache/compile := $(curdir)/zstd/compile
endif