aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-25 13:20:38 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-05 11:09:12 +0100
commitf6e6341d896adb78f9b496f71aab8f45e1742d5a (patch)
treebc4cd06f9a10e5e94c624bdcd374f41ac13a92ff /tools/Makefile
parenta46c9a4038f385e53b49b42a1e195b1fc3261842 (diff)
downloadupstream-f6e6341d896adb78f9b496f71aab8f45e1742d5a.tar.gz
upstream-f6e6341d896adb78f9b496f71aab8f45e1742d5a.tar.bz2
upstream-f6e6341d896adb78f9b496f71aab8f45e1742d5a.zip
tools: build libressl on all systems
Useful for having a more consistent build environment and finding API issues faster Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 5f4174e523..bc62b53680 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -26,7 +26,7 @@ tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
tools-y += sstrip make-ext4fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-image patch quilt yaffs2 padjffs2
tools-y += mm-macros missing-macros xz cmake scons bc findutils gengetopt patchelf
-tools-y += mtools dosfstools
+tools-y += mtools dosfstools libressl
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
tools-$(CONFIG_powerpc) += upx
tools-$(CONFIG_TARGET_x86) += qemu
@@ -70,11 +70,9 @@ $(curdir)/findutils/compile := $(curdir)/bison/install
$(curdir)/gengetopt/compile := $(curdir)/libtool/install
$(curdir)/patchelf/compile := $(curdir)/libtool/install
$(curdir)/dosfstools/compile := $(curdir)/autoconf/install $(curdir)/automake/install
-ifeq ($(HOST_OS),Darwin)
-tools-y += libressl
$(curdir)/mkimage/compile += $(curdir)/libressl/install
$(curdir)/firmware-utils/compile += $(curdir)/libressl/install
-endif
+
ifneq ($(HOST_OS),Linux)
tools-y += coreutils
endif