aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorKuang Rufan <master@a1983.com.cn>2018-09-27 22:08:35 +0800
committerJo-Philipp Wich <jo@mein.io>2019-01-22 11:28:49 +0100
commiteb31562370a3d7cd09598646a5ad50d3effcf1c0 (patch)
tree3a37b13e9c8a01c07d41b40d4a6cc49e778090e0 /tools/Makefile
parent74450124f606cb04bdd44684b6070a15dd0837bd (diff)
downloadupstream-eb31562370a3d7cd09598646a5ad50d3effcf1c0.tar.gz
upstream-eb31562370a3d7cd09598646a5ad50d3effcf1c0.tar.bz2
upstream-eb31562370a3d7cd09598646a5ad50d3effcf1c0.zip
tools/sed: fix incorrect dependency.
sed shall depend on xz instead of xz depends on sed. Signed-off-by: Kuang Rufan <master@a1983.com.cn>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 294f6fe07f..cacba5bcb4 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -99,9 +99,10 @@ $(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(patsubst %,$(c
tools-y += $(tools-core)
# make core tools depend on sed and flock
-$(foreach tool, $(tools-core), $(eval $(curdir)/$(tool)/compile += $(curdir)/sed/compile))
+$(foreach tool, $(filter-out xz,$(tools-core)), $(eval $(curdir)/$(tool)/compile += $(curdir)/sed/compile))
+$(curdir)/xz/compile += $(curdir)/flock/compile
-$(curdir)/sed/compile := $(curdir)/flock/compile
+$(curdir)/sed/compile := $(curdir)/flock/compile $(curdir)/xz/compile
tools-y += flock sed
$(curdir)/autoremove := 1