aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-28 13:44:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-28 13:44:04 +0000
commitd6a024240496434ae24ceb658c8fcc5763eb683d (patch)
tree8b7aea1f9ba7da5ee9c0d58b3227937a8c4eac3d /tools/Makefile
parente143bed1f19b55c5eac38d78a5c98f478fca88fc (diff)
downloadupstream-d6a024240496434ae24ceb658c8fcc5763eb683d.tar.gz
upstream-d6a024240496434ae24ceb658c8fcc5763eb683d.tar.bz2
upstream-d6a024240496434ae24ceb658c8fcc5763eb683d.zip
use $(curdir) again
SVN-Revision: 8208
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile28
1 files changed, 16 insertions, 12 deletions
diff --git a/tools/Makefile b/tools/Makefile
index ed2eae89d9..ea4ce7081a 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -7,25 +7,29 @@
# Main makefile for the host tools
#
-curdir:=tools
+file:=${lastword ${MAKEFILE_LIST}}
+curdir:=$(patsubst %/Makefile,%,${file})
# subdirectories to descend into
-tools/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
+$(curdir)/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
# builddir dependencies
-tools/squashfs/compile := tools/lzma/install
+$(curdir)/squashfs/compile := $(curdir)/lzma/install
# preparatory work
+define copy_include
$(STAGING_DIR)/include-host/.done:
- @mkdir -p $$(dirname $@)
- @cp tools/include/*.h $$(dirname $@)/
- @touch $@
+ @mkdir -p $$$$(dirname $$@)
+ @cp $(1)/include/*.h $$$$(dirname $$@)/
+ @touch $$@
+$(curdir)//prepare = $(STAGING_DIR)/include-host/.done
+endef
+$(eval $(call copy_include,$(curdir)))
# prerequisites for the individual targets
-tools/ := .config
-tools//prepare = $(STAGING_DIR)/include-host/.done
-tools//compile = $(1)/prepare
-tools//install = $(1)/compile
+$(curdir)/ := .config
+$(curdir)//compile = $(1)/prepare
+$(curdir)//install = $(1)/compile
-$(eval $(call stampfile,tools,tools))
-$(eval $(call subdir,tools))
+$(eval $(call stampfile,$(curdir),tools))
+$(eval $(call subdir,$(curdir)))