aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2019-02-15 17:02:23 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-02-20 18:51:31 +0100
commitc72b1d8468b027f6d42eacfd741e288f552bc27d (patch)
tree72b02e1386904dcaf804a9d5070f1801676b8c52 /tools/Makefile
parent6cdf08f02625975de32cce5ceab2e5d84a0134f0 (diff)
downloadupstream-c72b1d8468b027f6d42eacfd741e288f552bc27d.tar.gz
upstream-c72b1d8468b027f6d42eacfd741e288f552bc27d.tar.bz2
upstream-c72b1d8468b027f6d42eacfd741e288f552bc27d.zip
gemini: Generate harddisk image for DNS-313
This makes OpenWrt build an Ext2+Ext4 partitioned image for the D-Link DNS-313 with two blank partitions, a boot partition on /dev/sda3 and a rootfs partition on /dev/sda4. This uses the methods already used in apm821xx including the tricks to convert the generated Ext2 filesystem partition to version 1 so that the firmware bootloader will properly recognize it. We patch a bit around the build files to make sure we get the rootfs size set and that genext2fs is properly built. Tested on the D-Link DNS-313. Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [Fixing and tricksing] Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index cacba5bcb4..0123a759c8 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -37,7 +37,7 @@ tools-y += lzma squashfs4 zip
tools-$(BUILD_B43_TOOLS) += b43-tools
tools-$(BUILD_ISL) += isl
tools-$(CONFIG_USE_SPARSE) += sparse
-tools-$(CONFIG_TARGET_apm821xx) += genext2fs
+tools-$(CONFIG_TARGET_apm821xx)$(CONFIG_TARGET_gemini) += genext2fs
# builddir dependencies
$(curdir)/bison/compile := $(curdir)/flex/compile