aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-02 00:47:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-02 00:47:21 +0000
commit976b48b6540f9421ec63bf3c3c56ba942728cf35 (patch)
tree949cd2b9be83fd023192e5eb3be57718e4c9bd66 /tools/Makefile
parent4067bdf501ac6d199a7e34a55e2847210a939d5e (diff)
downloadupstream-976b48b6540f9421ec63bf3c3c56ba942728cf35.tar.gz
upstream-976b48b6540f9421ec63bf3c3c56ba942728cf35.tar.bz2
upstream-976b48b6540f9421ec63bf3c3c56ba942728cf35.zip
add cloog and ppl to the tools build for the graphite framework in gcc 4.4
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18264 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 0d91b1f956..8a5f36c284 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -19,6 +19,11 @@ tools-$(CONFIG_CCACHE) += ccache
tools-$(CONFIG_powerpc) += dtc
tools-dep += lzma
+ifdef CONFIG_GCC_VERSION_4_4
+ tools-y += ppl cloog
+ $(curdir)/cloog/compile := $(curdir)/ppl/install
+endif
+
# builddir dependencies
$(curdir)/pkg-config/compile := $(curdir)/sed/install
$(curdir)/squashfs/compile := $(curdir)/lzma-old/install